Galène videoconferencing server discussion list archives
 help / color / mirror / Atom feed
* [Galene] Yunohost galene
@ 2021-08-01  9:30 Google Fred
  2021-08-01 10:58 ` [Galene] " Juliusz Chroboczek
  2021-08-01 12:26 ` Alfredo “Fred” Vogel
  0 siblings, 2 replies; 14+ messages in thread
From: Google Fred @ 2021-08-01  9:30 UTC (permalink / raw)
  To: jch; +Cc: galene

Hi,
I have installed galene on my yunohost server and it works ok but disconnects with “ negotiation failed” error. Can you give me some advice how to eliminate this error? It happens on all the browsers and iOS devices which makes me think it is the server end that fails.
Keep safe 
Thanks for helping!

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: Yunohost galene
  2021-08-01  9:30 [Galene] Yunohost galene Google Fred
@ 2021-08-01 10:58 ` Juliusz Chroboczek
  2021-08-01 12:26 ` Alfredo “Fred” Vogel
  1 sibling, 0 replies; 14+ messages in thread
From: Juliusz Chroboczek @ 2021-08-01 10:58 UTC (permalink / raw)
  To: Google Fred; +Cc: galene

> I have installed galene on my yunohost server and it works ok but
> disconnects with “ negotiation failed” error.

That's very interesting.

 1. Is there anything non-standard in the group definition?  In
    particular, did you set the "codecs" field?

 2. Are there any further details in the log?

-- Juliusz

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: Yunohost galene
  2021-08-01  9:30 [Galene] Yunohost galene Google Fred
  2021-08-01 10:58 ` [Galene] " Juliusz Chroboczek
@ 2021-08-01 12:26 ` Alfredo “Fred” Vogel
  2021-08-01 12:44   ` Juliusz Chroboczek
  1 sibling, 1 reply; 14+ messages in thread
From: Alfredo “Fred” Vogel @ 2021-08-01 12:26 UTC (permalink / raw)
  To: Alfredo Vogel; +Cc: galene

[-- Attachment #1: Type: text/plain, Size: 910 bytes --]

Here are the logs again because I found that there is an error in the coturn-galene service which happened with the error of negotiation failed!
Maybe that helps to diagnose this.

The link to the logs is https://paste.yunohost.org/adohojadev <https://paste.yunohost.org/adohojadev>

Thanks for looking at this for me.
Regards
alfredo

> On 1 Aug 2021, at 10:30, Google Fred <alfredovogel@gmail.com> wrote:
> 
> Hi,
> I have installed galene on my yunohost server and it works ok but disconnects with “ negotiation failed” error. Can you give me some advice how to eliminate this error? It happens on all the browsers and iOS devices which makes me think it is the server end that fails.
> Keep safe 
> Thanks for helping!
> _______________________________________________
> Galene mailing list -- galene@lists.galene.org
> To unsubscribe send an email to galene-leave@lists.galene.org


[-- Attachment #2: Type: text/html, Size: 1707 bytes --]

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: Yunohost galene
  2021-08-01 12:26 ` Alfredo “Fred” Vogel
@ 2021-08-01 12:44   ` Juliusz Chroboczek
  2021-08-01 13:27     ` Alfredo Vogel
  0 siblings, 1 reply; 14+ messages in thread
From: Juliusz Chroboczek @ 2021-08-01 12:44 UTC (permalink / raw)
  To: Alfredo “Fred” Vogel; +Cc: galene

There's nothing wrong with the group definition file.

> The link to the logs is https://paste.yunohost.org/adohojadev

I don't see any logs from Galène -- these look like coturn logs.

Perhaps you should ask on the yunohost forums where to find the Galène
logs ?

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: Yunohost galene
  2021-08-01 12:44   ` Juliusz Chroboczek
@ 2021-08-01 13:27     ` Alfredo Vogel
  2021-08-01 17:22       ` Alfredo Vogel
  0 siblings, 1 reply; 14+ messages in thread
From: Alfredo Vogel @ 2021-08-01 13:27 UTC (permalink / raw)
  To: Juliusz Chroboczek; +Cc: galene

Yes, the logs are from the coturn logs because it was tha service that stopped with error if you look at the last few lines 48 - 52. I restarted the service coturn-galene.service manually ( systemctl restart coturn-galene.service)

I wilol ask the authors of the yunohost galéne package where the logs are! My galene .log is blank! 
alfredo

> On 1 Aug 2021, at 13:44, Juliusz Chroboczek <jch@irif.fr> wrote:
> 
> There's nothing wrong with the group definition file.
> 
>> The link to the logs is https://paste.yunohost.org/adohojadev
> 
> I don't see any logs from Galène -- these look like coturn logs.
> 
> Perhaps you should ask on the yunohost forums where to find the Galène
> logs ?
> _______________________________________________
> Galene mailing list -- galene@lists.galene.org
> To unsubscribe send an email to galene-leave@lists.galene.org


^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: Yunohost galene
  2021-08-01 13:27     ` Alfredo Vogel
@ 2021-08-01 17:22       ` Alfredo Vogel
  2021-08-01 17:34         ` Juliusz Chroboczek
  0 siblings, 1 reply; 14+ messages in thread
From: Alfredo Vogel @ 2021-08-01 17:22 UTC (permalink / raw)
  To: Alfredo Vogel; +Cc: Juliusz Chroboczek, galene

[-- Attachment #1: Type: text/plain, Size: 1322 bytes --]

Yep, got info from yunohost now: here is the galene log:
https://paste.yunohost.org/xejabafala <https://paste.yunohost.org/xejabafala>

thanks for your advice! Merci


> On 1 Aug 2021, at 14:27, Alfredo Vogel <alfredovogel@gmail.com> wrote:
> 
> Yes, the logs are from the coturn logs because it was tha service that stopped with error if you look at the last few lines 48 - 52. I restarted the service coturn-galene.service manually ( systemctl restart coturn-galene.service)
> 
> I wilol ask the authors of the yunohost galéne package where the logs are! My galene .log is blank! 
> alfredo
> 
>> On 1 Aug 2021, at 13:44, Juliusz Chroboczek <jch@irif.fr> wrote:
>> 
>> There's nothing wrong with the group definition file.
>> 
>>> The link to the logs is https://paste.yunohost.org/adohojadev
>> 
>> I don't see any logs from Galène -- these look like coturn logs.
>> 
>> Perhaps you should ask on the yunohost forums where to find the Galène
>> logs ?
>> _______________________________________________
>> Galene mailing list -- galene@lists.galene.org
>> To unsubscribe send an email to galene-leave@lists.galene.org
> 
> _______________________________________________
> Galene mailing list -- galene@lists.galene.org
> To unsubscribe send an email to galene-leave@lists.galene.org


[-- Attachment #2: Type: text/html, Size: 2483 bytes --]

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: Yunohost galene
  2021-08-01 17:22       ` Alfredo Vogel
@ 2021-08-01 17:34         ` Juliusz Chroboczek
  2021-08-01 18:59           ` Alfredo Vogel
  0 siblings, 1 reply; 14+ messages in thread
From: Juliusz Chroboczek @ 2021-08-01 17:34 UTC (permalink / raw)
  To: Alfredo Vogel; +Cc: galene

> https://paste.yunohost.org/xejabafala

Thanks.  The relevant line is this one:

    gotOffer: ICE Agent can not be restarted when gathering

It's this bug:

  https://github.com/pion/ice/issues/280

I'm a little surprised, since I was under the impression that I had worked
around the issue by moving the restart code to the offering side.  What
version of Galène are you using?  Do you know how to reproduce it?

-- Juliusz

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: Yunohost galene
  2021-08-01 17:34         ` Juliusz Chroboczek
@ 2021-08-01 18:59           ` Alfredo Vogel
  2021-08-01 19:19             ` [Galene] ICE Agent can not be restarted when gathering [was: Yunohost galene] Juliusz Chroboczek
  0 siblings, 1 reply; 14+ messages in thread
From: Alfredo Vogel @ 2021-08-01 18:59 UTC (permalink / raw)
  To: Juliusz Chroboczek; +Cc: galene

[-- Attachment #1: Type: text/plain, Size: 731 bytes --]

galene version is 0.3.5~ynh3
Sorry I forgot to answer your other question!
It happens all the time for remote clients: it just disconnects after a while…
now copied to list sorry

> On 1 Aug 2021, at 18:34, Juliusz Chroboczek <jch@irif.fr> wrote:
> 
>> https://paste.yunohost.org/xejabafala
> 
> Thanks.  The relevant line is this one:
> 
>    gotOffer: ICE Agent can not be restarted when gathering
> 
> It's this bug:
> 
>  https://github.com/pion/ice/issues/280
> 
> I'm a little surprised, since I was under the impression that I had worked
> around the issue by moving the restart code to the offering side.  What
> version of Galène are you using?  Do you know how to reproduce it?
> 
> -- Juliusz


[-- Attachment #2: Type: text/html, Size: 2001 bytes --]

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] ICE Agent can not be restarted when gathering [was: Yunohost galene]
  2021-08-01 18:59           ` Alfredo Vogel
@ 2021-08-01 19:19             ` Juliusz Chroboczek
  2021-08-01 19:35               ` [Galene] " Alfredo Vogel
  2021-08-02 13:41               ` Google Fred
  0 siblings, 2 replies; 14+ messages in thread
From: Juliusz Chroboczek @ 2021-08-01 19:19 UTC (permalink / raw)
  To: Alfredo Vogel; +Cc: galene

>> gotOffer: ICE Agent can not be restarted when gathering

> It happens all the time for remote clients: it just disconnects after a while…

It's definitely a bug in Pion (that should either be fixed in Pion or
worked around in Galène), but as far as I can tell one that should not
trigger unless you've got broken connectivity.

And, indeed, the log that you sent indicates that you've got some
networking issues:

  Aug 01 15:20:09 galene[516]: 2021/08/01 15:20:09 Relay test failed: timeout
  Aug 01 15:20:09 galene[516]: 2021/08/01 15:20:09 Perhaps you didn't configure a TURN server?

The sequence of events is as follows:

  1. the client starts a video by sending an offer;
  2. the server sends an answer and starts ICE candidate gathering;
  3. the client detects the failure after 30s or so and sends an ICE restart;
  4. the candidate gathering at the server isn't done yet, hence the error.

There are two things here that shouldn't happen if the network is
functioning: the candidate gathering shouldn't take so long, and the
client shouldn't be attempting to restart ICE.  Both of these indicate
that there's a firewall in the way and that no TURN server is accessible.

-- Juliusz

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: ICE Agent can not be restarted when gathering [was: Yunohost galene]
  2021-08-01 19:19             ` [Galene] ICE Agent can not be restarted when gathering [was: Yunohost galene] Juliusz Chroboczek
@ 2021-08-01 19:35               ` Alfredo Vogel
  2021-08-02 13:41               ` Google Fred
  1 sibling, 0 replies; 14+ messages in thread
From: Alfredo Vogel @ 2021-08-01 19:35 UTC (permalink / raw)
  To: Juliusz Chroboczek; +Cc: Alfredo Vogel, galene

Ok I am grateful for your time and input. I really do not know enough about the galene inner workings so I cannot find a solution myself. I have gone through the conf file of the turn server and opened all the ports in my modem and yunohost server as instructed by the docs. That is all I can do at my level of knowledge. So, I am opening a thread on the yunohost forum and see what the community can bring to it. Thanks again. 
In the end I will have to wait for future developments of the yunohost-galene package. For the time being it shall be an uninstall!!

> On 1 Aug 2021, at 20:19, Juliusz Chroboczek <jch@irif.fr> wrote:
> 
> 
>> 
>>> gotOffer: ICE Agent can not be restarted when gathering
> 
>> It happens all the time for remote clients: it just disconnects after a while…
> 
> It's definitely a bug in Pion (that should either be fixed in Pion or
> worked around in Galène), but as far as I can tell one that should not
> trigger unless you've got broken connectivity.
> 
> And, indeed, the log that you sent indicates that you've got some
> networking issues:
> 
>  Aug 01 15:20:09 galene[516]: 2021/08/01 15:20:09 Relay test failed: timeout
>  Aug 01 15:20:09 galene[516]: 2021/08/01 15:20:09 Perhaps you didn't configure a TURN server?
> 
> The sequence of events is as follows:
> 
>  1. the client starts a video by sending an offer;
>  2. the server sends an answer and starts ICE candidate gathering;
>  3. the client detects the failure after 30s or so and sends an ICE restart;
>  4. the candidate gathering at the server isn't done yet, hence the error.
> 
> There are two things here that shouldn't happen if the network is
> functioning: the candidate gathering shouldn't take so long, and the
> client shouldn't be attempting to restart ICE.  Both of these indicate
> that there's a firewall in the way and that no TURN server is accessible.
> 
> -- Juliusz
> _______________________________________________
> Galene mailing list -- galene@lists.galene.org
> To unsubscribe send an email to galene-leave@lists.galene.org

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: ICE Agent can not be restarted when gathering [was: Yunohost galene]
  2021-08-01 19:19             ` [Galene] ICE Agent can not be restarted when gathering [was: Yunohost galene] Juliusz Chroboczek
  2021-08-01 19:35               ` [Galene] " Alfredo Vogel
@ 2021-08-02 13:41               ` Google Fred
  2021-08-02 15:08                 ` Juliusz Chroboczek
  1 sibling, 1 reply; 14+ messages in thread
From: Google Fred @ 2021-08-02 13:41 UTC (permalink / raw)
  To: Juliusz Chroboczek; +Cc: galene

> Hiya Juliusz
Just solved this issue by following ericg on yunohost forum. I installed galene without turn and opened ports on router 1194. Now it passes relay test! Thanks for helping

> On 1 Aug 2021, at 20:19, Juliusz Chroboczek <jch@irif.fr> wrote:
> 
> 
>> 
>>> gotOffer: ICE Agent can not be restarted when gathering
> 
>> It happens all the time for remote clients: it just disconnects after a while…
> 
> It's definitely a bug in Pion (that should either be fixed in Pion or
> worked around in Galène), but as far as I can tell one that should not
> trigger unless you've got broken connectivity.
> 
> And, indeed, the log that you sent indicates that you've got some
> networking issues:
> 
>  Aug 01 15:20:09 galene[516]: 2021/08/01 15:20:09 Relay test failed: timeout
>  Aug 01 15:20:09 galene[516]: 2021/08/01 15:20:09 Perhaps you didn't configure a TURN server?
> 
> The sequence of events is as follows:
> 
>  1. the client starts a video by sending an offer;
>  2. the server sends an answer and starts ICE candidate gathering;
>  3. the client detects the failure after 30s or so and sends an ICE restart;
>  4. the candidate gathering at the server isn't done yet, hence the error.
> 
> There are two things here that shouldn't happen if the network is
> functioning: the candidate gathering shouldn't take so long, and the
> client shouldn't be attempting to restart ICE.  Both of these indicate
> that there's a firewall in the way and that no TURN server is accessible.
> 
> -- Juliusz
> _______________________________________________
> Galene mailing list -- galene@lists.galene.org
> To unsubscribe send an email to galene-leave@lists.galene.org

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: ICE Agent can not be restarted when gathering [was: Yunohost galene]
  2021-08-02 13:41               ` Google Fred
@ 2021-08-02 15:08                 ` Juliusz Chroboczek
  2021-08-02 19:00                   ` Alfredo “Fred” Vogel
  0 siblings, 1 reply; 14+ messages in thread
From: Juliusz Chroboczek @ 2021-08-02 15:08 UTC (permalink / raw)
  To: Google Fred; +Cc: galene

> Just solved this issue by following ericg on yunohost forum. I installed
> galene without turn and opened ports on router 1194. Now it passes relay
> test!

Excellent.  We still need to fix the other bug (the ICE restart failing).

-- Juliusz

^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: ICE Agent can not be restarted when gathering [was: Yunohost galene]
  2021-08-02 15:08                 ` Juliusz Chroboczek
@ 2021-08-02 19:00                   ` Alfredo “Fred” Vogel
  2021-08-02 19:44                     ` Juliusz Chroboczek
  0 siblings, 1 reply; 14+ messages in thread
From: Alfredo “Fred” Vogel @ 2021-08-02 19:00 UTC (permalink / raw)
  To: Juliusz Chroboczek; +Cc: galene

Just another silly question: how does Activity Detection work?
Apologies for my ignorance ..
alfredo

> On 2 Aug 2021, at 16:08, Juliusz Chroboczek <jch@irif.fr> wrote:
> 
>> Just solved this issue by following ericg on yunohost forum. I installed
>> galene without turn and opened ports on router 1194. Now it passes relay
>> test!
> 
> Excellent.  We still need to fix the other bug (the ICE restart failing).
> 
> -- Juliusz


^ permalink raw reply	[flat|nested] 14+ messages in thread

* [Galene] Re: ICE Agent can not be restarted when gathering [was: Yunohost galene]
  2021-08-02 19:00                   ` Alfredo “Fred” Vogel
@ 2021-08-02 19:44                     ` Juliusz Chroboczek
  0 siblings, 0 replies; 14+ messages in thread
From: Juliusz Chroboczek @ 2021-08-02 19:44 UTC (permalink / raw)
  To: Alfredo “Fred” Vogel; +Cc: galene

> Just another silly question: how does Activity Detection work?

It puts a purple frame around the person currently speaking.  It doesn't
work on Firefox, not sure about Safari.

-- Juliusz

^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2021-08-02 19:44 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-08-01  9:30 [Galene] Yunohost galene Google Fred
2021-08-01 10:58 ` [Galene] " Juliusz Chroboczek
2021-08-01 12:26 ` Alfredo “Fred” Vogel
2021-08-01 12:44   ` Juliusz Chroboczek
2021-08-01 13:27     ` Alfredo Vogel
2021-08-01 17:22       ` Alfredo Vogel
2021-08-01 17:34         ` Juliusz Chroboczek
2021-08-01 18:59           ` Alfredo Vogel
2021-08-01 19:19             ` [Galene] ICE Agent can not be restarted when gathering [was: Yunohost galene] Juliusz Chroboczek
2021-08-01 19:35               ` [Galene] " Alfredo Vogel
2021-08-02 13:41               ` Google Fred
2021-08-02 15:08                 ` Juliusz Chroboczek
2021-08-02 19:00                   ` Alfredo “Fred” Vogel
2021-08-02 19:44                     ` Juliusz Chroboczek

Galène videoconferencing server discussion list archives

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://lists.galene.org/galene

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 galene galene/ https://lists.galene.org/galene \
		galene@lists.galene.org
	public-inbox-index galene

Example config snippet for mirrors.


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git